Home > Error Code > Ubuntu Dpkg Error Code 2

Ubuntu Dpkg Error Code 2


asked 1 year ago viewed 11446 times active 13 days ago Linked 0 Whatever the command I give 0 Software Updater fails in Ubuntu 16.04 2 Cannot install anything PLEASE HELP install failed! [email protected] ~ $ sudo apt-get install bluefish Reading package lists... For details and our forum data attribution, retention and privacy policy, see here Ubuntu tips, tricks and solutions Home About Contact Follow Us: Failed Ubuntu apt-get upgrade corrupts the available file have a peek here

Continue on if there are no errors. But with a little research, I discovered that apt-get doesn't actually need the available file. Done The following packages were automatically installed and are no longer required: gnome-exe-thumbnailer libcapi20-3 libnss-winbind libosmesa6 libpam-winbind linux-headers-3.8.0-26 linux-headers-3.8.0-26-generic linux-image-3.8.0-26-generic linux-image-extra-3.8.0-26-generic p7zip ttf-droid ttf-liberation ttf-umefont ttf-unfonts-core winbind wine-gecko1.4 wine-gecko2.21 wine-mono0.0.8 wine1.5 Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the http://askubuntu.com/questions/603295/how-to-fix-dpkg-error-2

Sub-process /usr/bin/dpkg Returned An Error Code (2) Cydia

Edit the file /var/lib/dpkg/status in a text editor: sudoedit /var/lib/dpkg/status Go to line 4794 and change Package: wine1.6:any to Package: wine1.6 Check the directory /var/lib/dpkg/info for files whose name begins with Which towel will dry faster? Browse other questions tagged apt dpkg or ask your own question. Player claims their wizard character knows everything (from books).

If you don't have a backup copy to restore, you will have to apply some manual tricks, because installing the current version of dpkg with the package management tools cannot work Not the answer you're looking for? The issue appear when I want to update to mysql 5.5 version. Subprocess Installed Post-installation Script Returned Error Exit Status 1 What to do when majority of the students do not bother to do peer grading assignment?

Even the autoremove. (Reading database ... That would of removed the meta-package from the repositories. run sudo dpkg --configure -a run sudo apt-get -f install just in case. What steps have you executed to reach that output?

Need to get 0 B/47.4 MB of archives. Subprocess Installed Post-installation Script Returned Error Exit Status 2 After playing around a little, the following solved it for me: sudo apt-get --purge remove libc6-dev-i386 libc6-dev-x32 gcc-5-multilib gcc-multilib sudo apt autoremove -f sudo apt-get -f install share|improve this answer edited Tango Icons © Tango Desktop Project. Is it dangerous to use default router admin passwords if only trusted users are allowed on the network?

  1. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed
  2. Why do the Sparkfun and Adafruit Eagle libraries use smaller footprints than the manufacturer's recommended land pattern?
  3. more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science

Dpkg: Unrecoverable Fatal Error, Aborting:

From status: Code: /etc/sane.d/artec_eplus48u.conf 3672fe16e6b14a124ad74acd47941be9 From status-old: Code: /etc/sane.d/artec_eplus48u.conf 3672fe16e6b14a124ad74acd47941be9 The lines appear the same to me. http://lifeonubuntu.com/failed-ubuntu-apt-get-upgrade-corrupts-the-available-file/ First I didn't pay to much attention and I let the server running, but for now, there is a lot of upgrades to be fixed and I'm stuck. Sub-process /usr/bin/dpkg Returned An Error Code (2) Cydia Browse other questions tagged lubuntu dpkg or ask your own question. Dpkg: Error Processing Package Mysql-server (--configure): I shouldn't, the error is exactly the same as shown above.

E: Sub-process /usr/bin/dpkg returned an error code (100)0E: Sub-process /usr/bin/dpkg returned an error code (1) problem with dpkg?0could not exec dpkg! navigate here What's the output of sudo dpkg -C? Can you help with this problem? Thanks1. E: Unmet Dependencies. Try Using -f.

Need to get 0 B/2 548 kB of archives. How much more than my mortgage should I charge for rent? You can back it up, create an empty one, and then apt-get will recreate it: cd /var/lib/dpkg/ sudo mv available available.bak.fjl sudo touch available sudo apt-get update sudo apt-get upgrade Presto. http://centralpedia.com/error-code/ubuntu-error-code-1.html Ubuntu Logo, Ubuntu and Canonical © Canonical Ltd.

Last edited by ibjsb4; August 25th, 2013 at 10:15 PM. Dpkg: Warning: 'ldconfig' Not Found In Path Or Not Executable Code: sudo apt-get update && sudo apt-get upgrade Before that, I was trying to remove WINE. Updated and upgraded but still received the same error –TheUnicornCow Mar 2 '15 at 15:18 I got an error "ls: cannot access /var/cashe/apt/archives: No such file or directory" which

I did as you asked.

My advisor refuses to write me a recommendation for my PhD application unless I apply to his lab I have a black eye. [email protected]:~$ dpkg --version Debian `dpkg' package management program version (amd64). If you have a backup copy available from the time before the file was overwritten, you can restore that one, and the package management should work again. Sub-process /usr/libexec/cydia/cydo Returned An Error Code (2) y Get:1 http://us.archive.ubuntu.com/ubuntu/ raring/main aptitude-common all [669 kB] Get:2 http://us.archive.ubuntu.com/ubuntu/ raring/main libcwidget3 i386 0.5.16-3.4ubuntu1 [381 kB] Get:3 http://us.archive.ubuntu.com/ubuntu/ raring/main aptitude i386 [1,423 kB] Get:4 http://us.archive.ubuntu.com/ubuntu/ raring/universe ppa-purge all 0.2.8+bzr57

After this operation, 10.1 MB of additional disk space will be used. Once in a blue moon, I'm actually helpful. Separate namespaces for functions and variables in POSIX shells Why does Wikipedia list an improper pronunciation of Esperanto? this contact form dpkg: unrecoverable fatal error, aborting:
reading files list for package 'libhtml-parser-perl': Is a directory
E: Sub-process /usr/bin/dpkg returned an error code (2)

Do you want to help us debug the posting issues ? < is the place to report it, thanks ! To resolve that though, you may need to force remove that particular package. Lengthwise or widthwise. asked 2 years ago viewed 5808 times active 1 year ago Related 1MongoDB install errors / E: Sub-process /usr/bin/dpkg returned an error code (1)26“E: Sub-process /usr/bin/dpkg returned an error code (1)

Nobody can read in comments. –Braiam Oct 13 '14 at 20:51 | show 8 more comments 1 Answer 1 active oldest votes up vote 1 down vote accepted I suggested (in ain't nothing but a thing THE current(cy) in Documentation: https://help.ubuntu.com/community/PopularPages Happy ubuntu'n ! up vote 3 down vote favorite Every time I try to install or remove a package, I get this error. Also df -h –Braiam Oct 13 '14 at 20:30 Can you try: sudo apt-get -fv install bluefish and post the output? –ryekayo Oct 13 '14 at 20:36

How do really talented people in academia think about people who are less capable than them? Ubuntu 12.04.2 LTS (GNU/Linux 3.2.0-48-generic x86_64) Log in or register to post comments #2 Tue, 07/09/2013 - 10:18 andreychek Howdy, Is that libhtml-parser-perl package the only one that's causing an error? debconf: apt-extracttemplates failed: No such file or directory Extracting templates from packages: 86%E: Cannot get debconf version. There is a problem with either the hard disk or the memory.

Type in line 4794. See dpkg --license for copyright and license details. Equipo de Ubuntu-es Normas Documentación Inicie sesión o regístrese para comentar +1 0 -1 SOLUCIONADO pec Sáb, 23/05/2015 - 20:32 muchas gracias de verdad lo agradezco un monton, pude eliminar el Should I paste something from the terminal? –TheUnicornCow Mar 2 '15 at 15:11 1 I did get an error "rm: cannot remove ‘/var/cache/apt/archives/partial’: Is a directory".

I didnt download a debian.img, i downloaded an app which installs linux by downloading all components and sort of melting them together in a new debian.img so it probably is not and the better way to remove said Wine if via "ppa-purge' procedure. Understanding local rings How could a language that uses a single word extremely often sustain itself? very lightweight low power microcontroller with memory?

Beans 6,827 DistroUbuntu Re: E: Sub-process /usr/bin/dpkg returned an error code (2) No matter. Adv Reply Page 1 of 3 123 Last Jump to page: Quick Navigation New to Ubuntu Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums By using this website you agree to our Terms and Conditions of Use, Privacy Policy and Disclaimer.